Issues with updates - I am not able to update anything

Hi,

I am not able to update my Endless OS 3. In fact, I am not able to update anything for few months now. It shows me a note “new updates available”, it takes me to App center and than a message “Gnome missing”. It usually disappears! quickly and I didn’t take a photo. I was reading help topic. Tried to use Terminal app, but on my Acer laptop, this application doesn’t exist. There is the name in my applications, but when I press open, it takes me to app center with the message “this app doesn’t exist”. Please help!

Please send us a diagnostic by following the steps from this article:

https://support.endlessos.org/en/help-center/How-do-I-make-a-debug-log-of-Endless-OS

Hi Byron,

Here you can find the eos-diagnostics file. I am not able to access Terminal app. It doesn’t exist on my laptop.
eos-diagnostic-201016_161148_UTC 0200.txt (2.1 MB)

Hi Byron,

Did you check the rod diagnostics file? Could you tell me how to fix my issue with updates?

Regards,
Irena

You can enter a fullscreen terminal session by pressing Ctrl-Alt-F2 and logging in there. Then run:

eos-updater-ctl update --force
flatpak update --appstream -y
flatpak update -y

I know that this is a bit stupid question, but could you tell me with which log in details I should continue? I don’t have a password for my laptop. Did you mean the log in which I am using to enter here?

To log in on the console, enter your username and your password. Your username is the one you entered during the setup. Your username (according to the log) is irena.

To get back to the Graphical User Interface after you completed these commands, press Ctrl-Alt-F1

Thank you for the user name. The problem is that I don’t remember setting up anything. Is there a way to check the log in details? I don’t remember that I set up the account and I don’t have a password.

I managed to finish all steps. On the end it showed - error - gnome not found in red. I don’t think it worked