Last update recently

The last updates that run yesterday seem to have left me without the onboard keyboard on my laptop I am having to use an external keyboard. The built in one works perfectly OK with the windows 10 setup I have on the same laptop. Is/has anyone else had this?
I authorised the updates to go ahead I used the computer for some time then restarted it when it had loaded the Endless splash screen it then started to show the background checks usually hidden by the splash screen, which it had never done before. Another annoying thing which has been ongoing is the keyboard layout even though I have it set to UK it always runs as US layout don’t think there might be some connection?

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:


  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

Thank you I will do that tonight when I get in from work



as promised I have run the command and attached the file



eos-diagnostic-201116_192051_UTC+0000.txt (1.94 MB)

  1. Open the application called ‘Terminal’
  2. In this application run the command:

sudo eos-rollback

  1. Restart the computer

Right I have done that I have tested and it still loads up with
key board disabled I can use a small blue tooth one or a
large/full USB key board. Prior to the updates on the 15th I think
it was the keyboard was active I was using Firefox logged into
Face book. It had loaded normally that time. The Grub now shows in
advanced the previous version on top the newer version below I ave
run diagnostics again whilst in the earlier version. It does not
show a need to update to a new version as I thought it would after
the roll back. It is not really an issue I can always re install
Endless . I was evaluating it as I was considering getting a
couple of cheep/second hand netbooks and installing it for my
stepdaughter and daughter back in the Philippines for education
purposes when I can afford to.



eos-diagnostic-201117_181953_UTC+0000.txt (1.05 MB)

So, the keyboard is still not working after rolling back to 3.8.7 where it previously (before 3.9.0 got relased) worked?

If this is the case: Can you verify that your Notebooks internal keyboard is working by entering the BIOS with the internal keyboard.

Please keep us informed.

I have a same problem. internal keyboard not working.
only external keyboard working.

eos-diagnostic-201117_233626_UTC 0300.txt (1.7 МБ)

The laptop key board works perfectly on windows 10 which I have
set up to duel boot it works up to the point where I can use it to
choose to boot to windows or Endless or go into Advanced and use
the previous version of Endless but once it has completed booting
to the log in screen then it does not function. Also it does not
function once logged in. I will go and try to enter BIOS might
take a few attempts I have forgotten which F key it is and it does
not helpfully flash up on the screen at start up.



For people with a ASUS branded device:

Can you please execute the following snippet of code inside of a (EOS 3.9.0) Terminal:

sudo mkdir /etc/X11/xorg.conf.d
cat << EOF | sudo tee /etc/X11/xorg.conf.d/98-asus-wmi-hotkeys.conf
Section "InputClass"
        Identifier "Asus WMI hotkeys"
        MatchProduct "Asus WMI hotkeys"
        Option "Ignore" "on"


It seems that for some reason, the Xorg Server misinterprets the Hotkey Buttons on your Device as the actual Keyboard. After issuing these commands, reboot your device.

1 Like

Can you please provide the output of the following command in 3.9.0:

lsusb -t
sudo lsusb -v

For some reason, your internal keyboard even does not show up on the USB bus :-/

Thanks, internal keyboard and touchpad has worked.
Asus notebook.

Hi sorry for the delay I did not have time to do this before
going to work this morning and have only just got around to
getting in to the computer tonight. I put the first here it was
short and sweet the other information is a tiny bit longer so felt
best to put it into a PDF and attach

lsusb -t

  x@ lsusb -t

/: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p,
>__ Port 2: Dev 2, If 0, Class=Mass Storage, Driver=uas, 5000M
/: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/14p,
>__ Port 3: Dev 2, If 0, Class=Human Interface Device,
Driver=usbhid, 1.5M
>__ Port 4: Dev 3, If 0, Class=Human Interface Device,
Driver=usbhid, 1.5M
>__ Port 4: Dev 3, If 1, Class=Human Interface Device,
Driver=usbhid, 1.5M
>__ Port 5: Dev 4, If 0, Class=Mass Storage,
Driver=ums-realtek, 480M
>__ Port 6: Dev 5, If 0, Class=Wireless, Driver=btusb, 12M
>__ Port 6: Dev 5, If 1, Class=Wireless, Driver=btusb, 12M
>__ Port 10: Dev 6, If 0, Class=Video, Driver=uvcvideo, 480M
>__ Port 10: Dev 6, If 1, Class=Video, Driver=uvcvideo, 480M
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
>__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
>__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M



(Attachment eos lsusb.pdf is missing)

Hi, can you please also provide lsusb -v

I did as a PDF which was rejected I will do it as a text file tonight.

well try 3rd time do not make it easy to send large amounts of

eos text.txt (67.5 KB)

Interesting finding - thanks for looking into it! How did you detect this?

There are entries in the Xorg log containting lines like

Asus WMI hotkeys: device is a keyboard

where it really should be a switch device.


Early finish friday.

  I am wondering the original Motherboard was built in a factory

owned by Asus (not sure if it might have been manufactured before
or after they parted company) that burnt out and has been replaced
by a motherboard from another computer (don’t know what it was
done by a friend of a friend) but the board has the same ID
number. might that play a part in my problem? As my computer is a
Novatech I did not take any action.




after investigating all the logs you sent, i’m still unsure, why the internal Keyboard does not work. I have the assumption that it has to do with the BIOS, but not with the settings but rather with a Bug in the ACPI implementation (Linux is by far more strict when it comes to such issues than Windows).

My assumption is based on the following log entries:

Initialized Local Variables for Method [XPLD]:
Nov 15 23:47:47 localhost kernel:   Local0: 00000000e6ff19e3 <Obj>           Integer 0000000000000000
Nov 15 23:47:47 localhost kernel: Initialized Arguments for Method [XPLD]:  (1 arguments defined for method invocation)
Nov 15 23:47:47 localhost kernel:   Arg0:   000000006ddd40c7 <Obj>           Integer 0000000000000013
Nov 15 23:47:47 localhost kernel: ACPI Error: Aborting method \_SB.XPLD due to previous error (AE_AML_PACKAGE_LIMIT) (20200528/psparse-531)
Nov 15 23:47:47 localhost kernel: ACPI Error: Aborting method \_SB.PCI0.XHC.RHUB.SSP5._PLD due to previous error (AE_AML_PACKAGE_LIMIT) (20200528/psparse-531)
Nov 15 23:47:47 localhost kernel: ACPI BIOS Error (bug): AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20200528/exoparg2-396)

This message occurs many times. There’s a newer BIOS available for your device (from what i’ve read on Google), but i don’t know where. Your Mainboard is a whitelabel product used by many different Notebook vendors, but in reality is built by Pegatron (Model CB15).

Good luck.