Unable to update/install anything


#82

eos-diagnostic-180617_233932_UTC 0300.txt (757.8 KB)


#83

Hello again,

I am unable to update from EndlessOS 3.3.15, but I can uninstall and install the apps. The “No updates available” message appears after I click on the link “Check for updates now” in Settings > System > Details.

I have tried every solution described here, but without success.

Please find attached my diagnostics report.

Looking forward for your answer,

Alexioeos-diagnostic-180624_214540_UTC 0300.txt (423.5 KB)


split this topic #85

2 posts were split to a new topic: Unable to update Endless OS: disk is full


#87

@Alexio please try opening Terminal and running the following command:

sudo grub-editenv - create

If you have a password on your account, you will be asked to enter it. Nothing will appear on screen when you do – this is normal. Now reboot your computer: with luck you will now be running a newer version.


Impresoras compatibles con Endless 2018
#88

There was a later post dated Dec 2017 along the same lines that solved the problem for me regarding Endless Platform Framework ALONE not updating (flatpak apps were updating OK). However the problem has returned ( now in 3.4.5) until I run the command again in Terminal:
sudo eos-fix-ostree-repo
This removes the non-performing Framework update and says “Software is up to date”.
Does this mean Framework is actually up to date or are we just removing a genuine error in the system?


#89

i tried this but having this message only.
i dont know where to start

Can’t save diagnostic file to /sysroot/home/gianryahj14yahoocomph/eos-diagnostic-181030_133650_UTC+0800.txt: Failed to create file “/sysroot/home/gianryahj14yahoocomph/eos-diagnostic-181030_133650_UTC+0800.txt.NM2KRZ”: Read-only file syste


split this topic #90

A post was split to a new topic: “Invalid UTF-8” for user flatpak repo


#91

Update Endless OS for the latest Endless OS 3.5 release to download the update for Endless OS 3.5 just go to App center


#93

I did update it however the problem still exist. even when I tried to open the app center I got the same message


#94

I try to install Thunderbird and failled. Run diagnostic and the following file came:
eos-diagnostic-181109_222835_UTC 0000.txt (772.1 KB)
I tried install another ones and the result was the same as Thunderbird.
Need help please.


#96

Hi,

It looks like you tried to install Thunderbird using the command flatpak install --from https://flathub.org/repo/appstream/com.thunderbird.Client.flatpakref which is not correct. The correct command would be flatpak install --from https://flathub.org/repo/appstream/org.mozilla.Thunderbird.flatpakref


#97

can you help me? I get the same problem. I cant update and install my app in app center. This is when i type eos-diagnostics in terminal : eos-diagnostic-181112_182734_UTC 0700.txt (997.4 KB)


#98

Update Endless OS for the latest Endless OS 3.5 release to download the update for Endless OS 3.5 just go to App center


#99

I try to update, but it always fail. They say something went wrong. Beside that, it always fail too when i am trying to update endless platform. I am sorry if my english is bad. Thank you for your reply. Please help me, because i cant update libre office which is really important for me because i cant do my task in collage.


#100

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#101

eos-diagnostic-181125_141631_UTC 0700.txt (1.1 MB)


#102

@wjt Could help? :endless:


#103

@Popi_Sopmawati I see errors like “Could not connect: Connection refused” in your log so I wonder if there’s a problem with your Internet connection. Could you open a Terminal, type “ping ostree.endlessm.com”, hit Enter, and paste the output of that here?


#104

Thank you for your help. It works now.


#105

Thank you for your help, It works now.