Wifi isnt working


#1

Please attach the eos-diagnostic log file for any Endless OS problems, and a screenshot or camera image of the error message itself.

To generate an eos-diagnostic file:

  1. Open the application called ‘Terminal’. You can search for it by typing into the search bar on the desktop.
  2. In the Terminal, type the command: eos-diagnostics
  3. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze it and seek a possible solution

#2

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#3

First of all i want to clarify few things so that my issue will be quickly resolved by endless os community.

i have created this topic by mistake without explaining in detail my issue and i didnt attached the eos diagnostic file.so i created another thread and i have uploaded this diagnostic file in hope that moderator would see this and delete the first topic that i have created,but he allowed this topic that i am now responding.
i will now explain the issue.
About a month ago my laptop broke down and i sent it to service to repair it.it came in yesterday and they replaced the motherboard of laptop.everything worked but endless os didnt recognize wifi connection anymore.i think that the problem could be a mac adress.is it possible that endless os remembered the old mac adress before the laptop broke down and now it isnt recognizing the wifi card of the new motherboard that was replaced.or maybe the wifi card isnt working on new motherboard.i wouldnt like to sent it again to service to repair it because i would wait another month so that they would fix it.maybe its software problem and not hardware.i have now wifi connection through usb wifi dongle.so please somebody help me to fix this problem!!! !eos-diagnostic-191127_204258_UTC 0100.txt (1.9 MB)


#4

this might be helpful


#5

I would recommend you to completely remove any obsolete connections.

Open a terminal and write:

nmcli con

This will show all currently NetworkManager registered connections, something like

Lobby 0f91bb0d-e2be-4f8a-a00e-457c8bdaf9a9 802-11-wireless never
TTH-Zentral 2d3ddca9-772f-47d9-99a1-1559640b0f25 802-11-wireless never
attwifi 6be3c5aa-fc85-415c-96e4-5583b25c23bb 802-11-wireless never
uni-koblenz 8a0d1d51-672c-4ded-ad92-18e27b8215df 802-11-wireless

Then use:

nmcli con delete uuid 0f91bb0d-e2be-4f8a-a00e-457c8bdaf9a9

to delete obsolete entries. replace the uuid with the correct one, then reboot.

The Intel Wireless-AC 3168NGW WiFi card in your system seems to be recognized and is also supported by this version of EOS. I additionally would recommend you to upgrade to the latest version available as soon as possible.

After the reboot, you should be able to connect using the Intel card. Make sure that it’s enabled by entering:

nmcli r wifi on

Then scan for networks:

nmcli d wifi list

Then connect:

nmcli d wifi connect MYSSID password MYPASSWORD

Replace MYSSID and MYPASSWORD


#6

i did everything you said and first time it created new connection on dlink usb wifi card but not on intel wifi card.and second time when i tried disconnecting usb wifi card it couldnt find wifi connection from intel card.i am starting to believe that intel card isnt working right and might be faulty.i have tried everything from cloning the mac adress to updating endless os to latest version but it just cannot detect wifi connection from intel wifi card.in screenshot that i have attached it shows intel wifi card without dlink usb wifi card.it says that state is disconnected and connectivity is limited and everything else is in enabled mode(i mean green words).is this a software or hardware problem,i am starting to wonder.


#7

To check the details it would be good if you:

  1. Clean reboot with no USB wifi adapter present at any point during this test
  2. Note the date and time
  3. Attempt to connect to your wifi network - either through endless UI, or through nmcli
  4. Collect eos-diagnostics log at this point
  5. Post on this forum: eos-diagnostics log, network name (SSID) of the network you tried, time and date when the connection was attempted.

#8

… and additionally, to make sure that your interface is at least able to receive/transmit something, can you please run:

iw list

this will output information about the installed intel wireless card, including it’s assigned device name, something like:

phy#0
	Unnamed/non-netdev interface
		wdev 0x2
		addr 20:79:18:e2:c6:2f
		type P2P-device
		txpower 0.00 dBm
	Interface wlp4s0
		ifindex 3
		wdev 0x1
		addr 20:79:18:e2:c6:2e
		ssid Test
		type managed
		channel 44 (5220 MHz), width: 80 MHz, center1: 5210 MHz
		txpower 17.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
			0	0	0	0	0	0	0	0		0

Now remember the assigned device name (wlp4s0 in my case), and type:

nmcli device wifi list ifname wlp4s0

This will perform a SSID scan on the given adapter and show the results, something like:

IN-USE  SSID                      MODE   CHAN  RATE        SIGNAL  BARS  SECURITY    
        Test24                    Infra  5     130 Mbit/s  100     ▂▄▆█  WPA2        
*       Test                      Infra  44    270 Mbit/s  87      ▂▄▆█  WPA2        
        Android-Handscanner-Test  Infra  11    195 Mbit/s  59      ▂▄▆_  WPA2        
        raven                     Infra  11    195 Mbit/s  57      ▂▄▆_  WPA2 802.1X       
        raven                     Infra  100   405 Mbit/s  47      ▂▄__  WPA2 802.1X 
        Android-Handscanner-Test  Infra  100   405 Mbit/s  47      ▂▄__  WPA2        

If you see some results it means that your card is actually working and the problem can be narrowed down.


#9

when i type in iw list it outputs large text which isnt similar like in your example.and if i try to do SSID scan it doesnt list intel wifi card.i have uploaded latest eos diagnostics file.
eos-diagnostic-191129_132422_UTC 0100.txt (829.6 KB)


#10

Very interesting. I don’t see anything that points into the direction that the hardware has any problems. Your Intel Wireless interface is even recognized correctly and got the name wlp2s0 assigned.

What happens if you try to force a connection with:

nmcli device wifi connect YOURSSID password YOURPASSWORD ifname wlp2s0 hidden yes

Before issuing the command above, open another Terminal and write:

journalctl -f -u NetworkManager

To eventually see more details about whats going on. Post the output of both terminals in this Thread.

/edit: Got another idea. You told us, that you had your notebook for service. Sometimes, they don’t attach the IPEX connector for the antennas correctly. So eventually, your issue is simply that your card get’s no signal?

The IPEX connectors are the two on the upper right. You can attach them with a needle nose plier, but probably need some kind of magnifying glass too, as they are really small.


#11

i doubt now that anything can be fixed on the software side because probably as you have said wifi card isnt attached to laptop motherboard correctly.problem is that intel wifi card just isnt recieving any signal from my adsl2+ router.i am not sure that i can fix the issue myself so i will take the laptop to service again even if i dont like to wait for another month to get it again.thank you for your time and patience.


#12

does anybody know something about this error message in Logs program.it mentions intel wifi card name wlp2s0.


#13

Before sending back your device for service, let’s try to switch back to some older firmware for your card. Download the following file and save it to ~/Downloads:

sudo bash
mkdir -p /usr/local/lib/firmware
gzip -dc /sysroot/home/boris/Downloads/iwl.tgz | tar -xvf - -C /usr/local/lib/firmware

Every Intel Wireless card needs some firmware to be loaded during boot - these files are normally shipped with the Linux Kernel used in EOS, but we will save older versions of this firmware files to a directory which is used first.

Eventually something happend to the latest firmware in the Linux Kernel so we are switching to a older one.

Reboot after executing the above commands and then try again.


#14

i am interested if this will work.but i am getting some errors when i try to execute those commands.note that i have endless os in croatian language so Downloads means Preuzimanja.


#15

I had an error in my uploaded file, just redownload the file and try again.


#16

now everything went smoothly but it didnt help.i want to try one thing more before i return the laptop to service.how can i change the mac adress of intel wifi card???maybe this could help.


#17
nmcli connection modify wifi 802-11-wireless.cloned-mac-address AA:BB:CC:DD:EE:FF

#18

can you please explain what to write when i want to change this mac adress A0:AF:BD:2B:76:D6 in for example AA:BB:CC:DD:EE:FF.i am getting error: unknown connection ‘wifi’ when i try directly your command line.


#19

It’s because wifi stands for the name of the connection and depends on your local configuration. To see the connection names, use:

nmcli con

If you just want to make sure that there are no leftovers from your previous wireless card:

sudo bash
systemctl stop NetworkManager
rm /etc/NetworkManager/system-connections/*
systemctl start NetworkManager

This will erase all your stored network configurations, including wireless networks, VPN connections, … and allows you to completely start from scratch.