RTL8821CE Wi-Fi not working in 4.0.0

eos-diagnostic-211126_122719_UTC 0630.txt (1.2 MB) I have wifi issue . my computer does not connect wifi after 4.0.0 update. please help

Hello
It’s simple, All you have to do is to follow these next commands

Open your terminal and paste these commands

mkdir lab && cd lab
sudo apt-get update
sudo apt install bc module-assistant build-essential dkms git curl wget
git clone https://github.com/tomaspinho/rtl8821ce
cd rtl8821ce
sudo m-a prepare
sudo reboot

And voila, if you have any issue contact me on hirechbaghdadbelkheir31@gmail.com, and i’d be happy to guide you with google meet or zoom session

1 Like

hi,

same issue here. tried what you said, here what I got:

after:
sudo apt install bc module-assistant build-essential dkms git curl wget
I got:
dpkg: error: unable to access the dpkg database directory /var/lib/dpkg: Read-only file system
E: Sub-process /usr/bin/dpkg returned an error code (2)

AND

after:
sudo m-a prepare

I got:
sudo: m-a: command not found

Hello.

Try to do the next :
sudo dpkg --configure -a
sudo apt -f install

And try again, if this doesn’t work please contact me directly on the email so i can assist you directly online

It’s not possible to run such procedures on Endless OS unfortunately, since the root filesystem is read-only. https://support.endlessos.org/en/endless-os/tech-intro

We are currently investigating some problems with the official Linux driver for RTL8821CE and hope to publish an OS update if solutions emerge.

Dear @Daniel

I believe it would be more efficient if you allow for Snap and Flatpak or Appimage to be run on top of the system.
as for overlayfs, there might be other options that makes the experience more suitable, such as making the default installation on /home/$user/.data

Hello Endlles Team Members !
Since endlessOS V4.0.0 update on my ASUS X515JA-BQ129 (with RTL8821CE ) wifi not working !!! Too bad after very good surprise to work everydays with this very nice linux system out of the box I can’t wait more than 24h without wifi/internet connection …How to much time waiting for OS update??? Does I say goodbye to your world and switch to microsoft one??
please find my probe URL for diag hardaware info : https://linux-hardware.org/?probe=5f9f761ed0

My computer had Endless OS 3.3.20-nexthw1 and wi-fi was working.
I had some other problems:
1- TLS Certificate problem: TLS certificate
the solution was updating the OS.
but;
2- It was not possible. OS Version 3.3.20-nexthw1 (200116-021118) - Can't Update to Anything

So, I downloaded Endless 4 and created a bootable USB drive and installed it.

Now, I can neither go back to 3.3.20-nexthw1 nor install wireless driver…

Sorry for the inconveniences here. We’re making some progress on RTL8822CE improvements and hope to offer an updated version soon.

We have released Endless OS 4.0.1 which resolves several issues with RTL8821CE Wi-Fi. If you can connect to the internet another way (such as a wired connection), check for updates in the App Center. If you’re not able to connect to the internet another way, you can boot the previous OS version and check for updates there.

1 Like

Thanks, this fixed it.
I had no idea you could boot the previous OS version, that would have been useful to know a few days ago. If you can mention it as a temporary solution in other cases like this it could help some people.

Thank you for the confirmation and feedback!

Hello ! I’m back from holidays and make the update today and can confirm that released Endless OS 4.0.2 resolves the issue with RTL8821CE Wi-Fi.
Thanks to all the Team and Happy New year !