Wifi-USB stick is not recognized

My USB wifi stick
Bus 002 Device 004: ID 0bda:1a2b Realtek Semiconductor Corp. RTL8188GU 802.11n WLAN Adapter (Driver CDROM Mode)
is not recognized in endless os. I would really appreciate help, because this is the notebook of a friend.
I already got it running in Ubuntu, but I had boot problems, which I don’t have with endless.
eos-diagnostic-210511_141219_UTC 0200.txt (548.2 KB)

You’re probably out of luck as the chipset used in the WIFI-Dongle isn’t supported very well in Linux in general (1) and totally unsupported in EOS.

1: https://github.com/McMCCRU/rtl8188gu

What about this one? Realtek RTL8192EU. I have just bought it on Amazon. It says it is supported by Linux, but I couldn’t see in the offer from Kernel 2.6.18 - 3.10.10. This is annoying. Is it so difficult to keep existing drivers in the Kernel?

I think it’s better to publish the concrete products supported by EOS instead of saying which chipsets are not supported. I cannot buy WIFI-dongles until I have got one which works.
Thankseos-diagnostic-210512_124827_UTC 0200.txt (962.0 KB)

This one should work, it’s recognized by your system according to the diagnostic.

Check the following page for Up-to-Date information on which Hardware is supported by the Linux Kernel in general:

To make things simple, most hardware supported by the latest LTS release of Ubuntu is also supported on EOS.

The other one from yesterday was also recognized by the diagnostic, but I couldn’t install it. In Ubuntu I was able to after a strong effort with github.com. But Ubuntu didn’t boot after the installation, so I came to endless.

Here the result: https://linux-hardware.org/?view=search&vendor=TP-link&name=TL-WN823N#list

Could someone please give me the commands for the installation? The ones for Ubuntu don’t work here, because the packages are different.

No, the first one wasn’t recognized, it just showed up as a connected device, but no driver picked it up and made it usable. The later one with a RGL8192EU has been successfully grabbed by the driver and initialized:

mai 12 12:15:30 endless kernel: usb 2-1.1: rtl8xxxu: Loading firmware rtlwifi/rtl8192eu_nic.bin
mai 12 12:15:32 endless kernel: usbcore: registered new interface driver rtl8xxxu
mai 12 12:15:32 endless kernel: rtl8xxxu 2-1.1:1.0 wlxd03745df8068: renamed from wlan0
mai 12 12:15:33 endless NetworkManager[420]: <info>  [1620814533.7746] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/ieee80211/phy0/rfkill0) (driver rtl8xxxu)

So can you please delete any existing WIFI connections and try to reconnect.

Sorry, I didn’t see the WIFI tab, only the network tab. It’s trying to connect to the wifi-router, but it doesn’t get finally connected. The same with my mobile hotspot. What can it be?eos-diagnostic-210512_144509_UTC 0200.txt (1.2 MB)

I already did a reboot.

The WIFI standard of the router is 11n+11g. Can that cause an issue? I cannot change these parameters. The kind of encryption doesn’t change anything either.

It seems that for some reason, the authentication to the Android Phone Hotspot and your Fritzbox fails. Can you please do the following:

  1. Create a file with content like this:

(replace with the actual data of your network).
2. Save this file as wireless.conf to your Home directory
3. Run the following command for about 20 seconds, then press Ctrl-C to terminate it

sudo wpa_supplicant -cwireless.conf -Dnl80211,wext -iwlxd03745df8068 -dd 2>&1 | tee ~/wpa.txt
  1. Upload the generated file wpa.txt from your Home directory to this Thread for further analysis.

ssid = Fritzbox xxx?
psk = Android hotspot?

Here is the outcome:

wpa.txt (709 Bytes)

ssid = Name of your WLAN (e.g. “AndroidAP” or “FRITZ!Box 7362 SL”)
psk = Key used to connect to the WLAN


wpa.txt (23.1 KB)

For Fritzbox

wpa.txt (6.8 KB)

For Android

Can you please run the following command and then try again to connect to your wireless network.

echo 0 | sudo tee /sys/class/rfkill/rfkill0/soft

It does not work. Would it be possible to access my laptop from remote somehow?

I have the plugged in the third Dongle now. This is the diagnostics file:

eos-diagnostic-210512_200830_UTC 0200.txt (963.8 KB)

I think it’s easier to create a list of wifi usb-sticks that work with Debian and/or EOS. Would that be possible? I would like to handover this notebook still this week to a friend. A direct link to Amazon would also be welcome.

How much does it cost to get this solved? I want to contribute something to the community.

It cost nothing - just contribute your time to get this fixed together so that others with similar issues can look up (hopefully) a solution :slight_smile:

Currently digging through the logfile to see whats going on. From my point of view, the second dongle you tried (the one with a RTL8192EU chipset) should have worked after issuing the last command.

Let’s focus on this device first. Please reconnect it and issue the commands in the given order:

echo 0 | sudo tee /sys/class/rfkill/rfkill0/soft
sudo wpa_supplicant -cwireless.conf -Dnl80211,wext -iwlxd03745df8068 -dd 2>&1 | tee ~/wpa.txt

The first line will Unblock the device so that it’s available in general, the second one will try to authenticate with your network.